آی تی رسان/ اگر این مورد اصلاح نشود، این آسیب پذیری می‌تواند برای دستیابی به دیتای سرویس مورد سوء استفاده قرار گیرد.

یک محقق امنیتی این آسیب پذیری را در محصولات فایروال سیسکو کشف کرده است که می‌تواند توسط برخی از افراد برای انکار سرویس (DoS) مورد سواستفاده قرار گیرد.

این آسیب‌پذیری که به‌عنوان CVE-2021-34704 با امتیاز CVSSv3.0 8.6 ردیابی می‌شود، توسط محقق فناوری‌های مثبت، نیکیتا آبراموف، در Cisco Adaptive Security Appliance (ASA) و Cisco Firepower Threat Defense (FTD) این غول شبکه پیدا شد.

به گفته آبراموف، به هیچ گونه امتیاز بالا یا دسترسی ویژه‌ای برای آسیب زدن به سرویس نیاز نیست. در عوض، هکر‌ها می‌توانند یک درخواست ساده که در آن تنها اندازه یکی از قطعات با آنچه از دستگاه انتظار می‌رود تفاوت دارد را به سرویس ارسال کنند. از اینجا، تجزیه بیشتر درخواست باعث سرریز بافر می‌شود و سیستم به طور ناگهانی خاموش شده و سپس دوباره راه‌اندازی می‌شود.

آبراموف در بیانیه مطبوعاتی خود جزئیات بیشتری در مورد اینکه چگونه می‌توان در صورت سوء استفاده از این آسیب پذیری، عملیات تجاری را مختل کرد، ارائه کرد و گفت:

«اگر هکرها عملکرد Cisco ASA و Cisco FTD را مختل کنند، یک شرکت بدون فایروال و دسترسی از راه دور (VPN) می‌ماند. اگر حمله موفقیت آمیز باشد، کارمندان یا شرکای راه دور نمی‌توانند به شبکه داخلی سازمان دسترسی پیدا کنند. و دسترسی از خارج محدود خواهد شد. در عین حال، خرابی فایروال محافظت از شرکت را کاهش می‌دهد. همه اینها می‌تواند بر فرآیندهای شرکت تأثیر منفی بگذارد، تعاملات بین بخش‌ها را مختل کند و شرکت را در برابر حملات هدفمند آسیب پذیر کند.»

خودداری از ارائه خدمات
در یک توصیه امنیتی جدید، سیسکو هشدار می‌دهد که آسیب‌پذیری‌های متعددی در رابط خدمات وب سیسکو ASA و Cisco FTD کشف شده است که می‌تواند به یک مهاجم غیرقانونی و از راه دور اجازه دهد تا شرایط انکار سرویس (DoS) را ایجاد کند.

این شرکت همچنین توضیح داد که این آسیب‌پذیری‌ها «به دلیل اعتبارسنجی ورودی نامناسب هنگام تجزیه درخواست‌های HTTPS هستند و مهاجم می‌تواند با ارسال یک درخواست HTTPS مخرب به دستگاه آسیب‌دیده از آن سوء استفاده کند.»

خوشبختانه، سیسکو به‌روزرسانی‌های نرم‌افزاری را منتشر کرده است که این آسیب‌پذیری‌ها را برطرف می‌کند، اما شایان ذکر است که هیچ راه‌حل قطعی برای رفع این مشکل وجود ندارد، به این معنی که اگر دستگاهی دارید که دارای Cisco ASA یا Cisco FTD با پیکربندی آسیب‌پذیر AnyConnect یا WebVPN است، نصب این به‌روزرسانی ها حداقل کاری است که می‌توانید انجام دهید.

در کانال آی‌تی و ™CanaleIT هم کلی عکس و ویدئوی دسته اول و جذاب داریم